You are browsing the Symfony 4 documentation, which changes significantly from Symfony 3.x. If your app doesn't use Symfony 4 yet, browse the Symfony 3.4 documentation.

The Symfony Polyfill / PHP 7.3 Component

4.2 version
Maintained Unmaintained

The Symfony Polyfill / PHP 7.3 Component

This component provides some PHP 7.3 features to applications using earlier PHP versions.

Installation

1
$ composer require symfony/polyfill-php73

Alternatively, you can clone the https://github.com/symfony/polyfill-php73 repository.

Note

If you install this component outside of a Symfony application, you must require the vendor/autoload.php file in your code to enable the class autoloading mechanism provided by Composer. Read this article for more details.

Usage

Once this component is installed in your application, you can use the following functions, no matter if your PHP version is earlier than PHP 7.3.

Provided Functions

This work, including the code samples, is licensed under a Creative Commons BY-SA 3.0 license.