CVE-2015-2309: Unsafe methods in the Request class

Affected Versions

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, 2.5.X, and 2.6.X versions of the Symfony HttpFoundation component are affected by this security issue.

This issue has been fixed in Symfony 2.3.27, 2.5.11, and 2.6.6. Note that no fixes are provided for Symfony 2.0, 2.1, 2.2, and 2.4 as they are not maintained anymore.

Description

The Symfony\Component\HttpFoundation\Request class provides a mechanism that ensures it does not trust HTTP header values coming from a "non-trusted" client. Unfortunately, it assumes that the remote address is always a trusted client if at least one trusted proxy is involved in the request; this allows a man-in-the-middle attack between the latest trusted proxy and the web server.

The following methods are impacted: getPort(), isSecure(), and getHost(), and getClientIps().

Resolution

All impacted methods now check that the remote address is trusted, which fixes the issue.

The patch for this issue is available here.

Credits

I would like to thank Dmitrii Chekaliuk for reporting this security issue and James Gilliland for providing a fix.

If you have found a security issue in Symfony, please send the details to security [at] symfony.com and don't disclose it publicly until we can provide a fix for it.

Comments

I've updated to symfony 2.5.11 but still get message about this vulnerability
Sorry about incomplete post, but I'm using sensiolabs-security-checker
@Uladzimir Khramtsou: It should be ok now.
I've updated to symfony ~2.6.6 (Composer installed 2.6-dev) but still get message about this CVE

Comments are closed.

To ensure that comments stay relevant, they are closed for old posts.