Requirements for Running Symfony

3.4 version

Requirements for Running Symfony

Symfony 3.4 requires PHP 5.5.9 or higher to run, in addition to other minor requirements, when using the traditional installation based on the Symfony Standard Edition. If Symfony 3.4 is installed via the skeleton or website-skeleton (which is the recommended way for modern Symfony applications) the requirements are PHP 7.0.8 or higher.

To make things simple, Symfony provides a tool to quickly check if your system meets all those requirements. Beware that PHP can define a different configuration for the command console and the web server, so you need to check the requirements in both environments.

Checking Requirements for the Web Server

Symfony includes a config.php file in the web/ directory of your project. Open that file with your browser to check the requirements.

Once you've fixed all the reported issues, delete the web/config.php file to avoid leaking internal information about your application to visitors.

Checking Requirements for the Command Console

Open your console or terminal and run the following command provided by the symfony binary created when installing Symfony:

1
2
3
4
5
# checks if your computer/server is ready to run Symfony projects
$ symfony check:requirements

# use the --dir option to also check if some specific Symfony project is ready to be run
$ symfony check:requirements --dir=/path/to/my-project

This work, including the code samples, is licensed under a Creative Commons BY-SA 3.0 license.