WARNING: You are browsing the documentation for Symfony 4.1 which is not maintained anymore. Consider upgrading your projects to Symfony 4.3.

Requirements for Running Symfony

Requirements for Running Symfony

These are the technical requirements to run Symfony 4 applications:

Checking Requirements Automatically

To make things simple, Symfony provides a tool to quickly check if your system meets these requirements. In addition, the tool provides recommendations if applicable.

Run this command to install the tool:

1
2
$ cd your-project/
$ composer require symfony/requirements-checker

Beware that PHP may use different configurations for the command console and the web server, so you need to check requirements in both environments.

Checking Requirements for the Web Server

The requirements checker tool creates a file called check.php in the public/ directory of your project. Open that file with your browser to check the requirements.

Once you've fixed all the reported issues, uninstall the requirements checker to avoid leaking internal information about your application to visitors:

1
2
$ cd your-project/
$ composer remove symfony/requirements-checker

Checking Requirements for the Command Console

The requirements checker tool adds a script to your Composer configuration to check the requirements automatically. There's no need to execute any command; if there are any issues, you'll see them in the console output.

This work, including the code samples, is licensed under a Creative Commons BY-SA 3.0 license.