PHP4 is dead, long live PHP5!

Right from the beginning, symfony was built with PHP5 because it was the first really professional version of PHP. There was never any plan to support PHP4, because our clients would only accept a truly object-oriented language, with a proper handling of exceptions.

Today, PHP5 is 3 years old and yet, PHP4 is still the most broadly used version of PHP. Of course, some of the mostly used PHP applications are only compatible with PHP4, and web hosts cannot just drop PHP4 support without risking a major discontent among users. But as long as hosts support PHP4, software vendors will continue to develop with it, even though PHP4 code is often very hard to maintain, debug, and add up to. This is the problem of the chicken and the egg.

The Go PHP5 initiative wants to leverage the adoption of PHP5 among hosts and developers. Together with a few other famous open-source projects (including Drupal, Typo3, PhpMyAdmin, Propel, and Doctrine), symfony committed to have a minimum version requirement of at least PHP 5.2.0 as of February 5th, 2008. And first of all, the next version of symfony, the 1.1, released at the end of the Summer, will require at least PHP 5.1.0.

PHP5 is the future of PHP, and a good programming language. We must not let PHP4 give a bad image of PHP development in general. If, like us, you want to support this initiative, head to and add the name of your host company or software project.


Help the Symfony project!

As with any Open-Source project, contributing code or documentation is the most common way to help, but we also have a wide range of sponsoring opportunities.


OOOh! at last the entire world is going to move from that old PHP4 to the new "Object Oriented PHP5". I wish all the best for this.
As long as php4 is updated, php5 is doomed to fail...
I hope will stop supporting PHP4 and all distributives of Linux too, debian already deleted PHP4 from it's repository!
"As long as php4 is updated, php5 is doomed to fail..."

But php4 ISN'T being updated - nothing has been added in years! The only "updating" php4 has been seeing are bugfix releases. All the new work has been in php5 (and php6).
"symfony, the 1.1, released at the end of the Summer, will require at least PHP 5.1.0."

I'm using symfony 1.0.2, and it already needs PHP 5.1 (sorry can't remember which command failed some time ago when I tried 1.0.2 with PHP 5.0.4)

Be that's life, we need to go on the infinite and beyond !

Comments are closed.

To ensure that comments stay relevant, they are closed for old posts.