SymfonyWorld Online 2021 Winter Edition December 9 – 10, 2021 100% Online +20 talks and workshops

CVE-2015-2308: Esi Code Injection

Affected Versions

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, 2.5.X, and 2.6.X versions of the Symfony HttpKernel component are affected by this security issue.

This issue has been fixed in Symfony 2.3.27, 2.5.11, and 2.6.6. Note that no fixes are provided for Symfony 2.0, 2.1, 2.2, and 2.4 as they are not maintained anymore.


Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the `Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server.

HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of <script language="php"> tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation.

A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).


The fix implements a much stricter escaping on user submitted values to remove the possibility to inject PHP code.

The patch for this issue is available here.


I would like to thank Takeshi Terada of Mitsui Bussan Secure Directions, Inc. for reporting this security issue and Nicolas Grekas of for providing a fix.

Manage your notification preferences to receive an email as soon as a Symfony security release is published.
If you have found a security issue in Symfony, please send the details to security [at] and don't disclose it publicly until we can provide a fix for it.
Help the Symfony project!

As with any Open-Source project, contributing code or documentation is the most common way to help, but we also have a wide range of sponsoring opportunities.


The affected versions in the vulnerabilities seems wrong. It states

[>=2.0.0, =2.1.0, =2.2.0, =2.3.0, =2.4.0, =2.5.0, =2.0.0, =2.1.0, =2.2.0, =2.3.0, =2.4.0, =2.5.0, =2.6.0,
Sorry, meant

[>=2.0.0, =2.1.0, =2.2.0, =2.3.0, =2.4.0, =2.5.0, =2.6.0,
Oh damn, I should read better. I saw only ESI in the one, but it was a ESI vulnerability from last year. Shame on me :O!
it would be nice to add this to the security advisory database so it's catched by the security scanner
(looks like a pull request is there -
This is huge ! I didn't know the trick. Now XSS becomes RCE ! :)

Comments are closed.

To ensure that comments stay relevant, they are closed for old posts.