Requirements for Running SymfonyEdit this page
Warning: You are browsing the documentation for Symfony 2.4, which is no longer maintained.
Read the updated version of this page for Symfony 6.1 (the current stable version).
To run Symfony, your system needs to adhere to a list of requirements. You can
easily see if your system passes all requirements by running the
in your Symfony distribution. Since the CLI often uses a different
configuration file, it's also a good idea to check your requirements from
the command line via:
$ php app/check.php
Below is the list of required and optional requirements.
- PHP needs to be a minimum version of PHP 5.3.3
- JSON needs to be enabled
- ctype needs to be enabled
php.inineeds to have the
Be aware that Symfony has some known limitations when using a PHP version less than 5.3.8 or equal to 5.3.16. For more information see the Requirements section of the README.
- You need to have the PHP-XML module installed
- You need to have at least version 2.6.21 of libxml
- PHP tokenizer needs to be enabled
- mbstring functions need to be enabled
- iconv needs to be enabled
- POSIX needs to be enabled (only on *nix)
- Intl needs to be installed with ICU 4+
- APC 3.0.17+ (or another opcode cache needs to be installed)
short_open_tag = Off
magic_quotes_gpc = Off
register_globals = Off
session.auto_start = Off
If you want to use Doctrine, you will need to have PDO installed. Additionally, you need to have the PDO driver installed for the database server you want to use.