WARNING: You are browsing the documentation for Symfony 2.8 which is not maintained anymore. Consider upgrading your projects to Symfony 4.2.

The Symfony Polyfill / Iconv Component

2.8 version

The Symfony Polyfill / Iconv Component

This component provides a native PHP implementation of the iconv_* functions to users who run PHP versions without the iconv extension.

Installation

1
$ composer require symfony/polyfill-iconv

Alternatively, you can clone the https://github.com/symfony/polyfill-iconv repository.

Note

If you install this component outside of a Symfony application, you must require the vendor/autoload.php file in your code to enable the class autoloading mechanism provided by Composer. Read this article for more details.

Usage

Once this component is installed in your application, you can use the following constants and functions, no matter if the PHP iconv extension is installed or not in your server. The only function not implemented in this component is ob_iconv_handler.

Provided Constants

  • ICONV_IMPL (value = 'Symfony')
  • ICONV_VERSION (value = '1.0')
  • ICONV_MIME_DECODE_STRICT (value = 1)
  • ICONV_MIME_DECODE_CONTINUE_ON_ERROR (value = 2)

Provided Functions

These functions are always available:

These functions are only available when the mbstring or the xml extension are installed:

This work, including the code samples, is licensed under a Creative Commons BY-SA 3.0 license.