<!DOCTYPE html>
<html lang="en">
    <head>
        <!--[if IE]>
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <![endif]-->
        <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
        <meta charset="UTF-8" />
        <meta name="robots" content="index, follow, all" />
        <meta name="Author" content="Symfony" />
                    <meta name="description" content="Symfony 5: The Fast Track:   Acknowledgments Step 0: What is it about? Step 1: Checking your Work Environment Step 2: Introducing the Project Step 3: Going from Zero to Production Step 4: Adopting a M...">
                <meta name="Keywords" content="symfony3, symfony2, symfony, project, framework, php, php5, php7, open-source, components, symphony, symfony framework, symfony tutorial" />
                    <link rel="canonical" href="" />
        
                <link rel="search" type="application/opensearchdescription+xml" href="https://symfony.com/opensearch/documentation.xml" title="Symfony documentation" />

                <title>Symfony 5: The Fast Track (Symfony Docs)</title>

        <link rel="preconnect" href="https://www.google-analytics.com">
        <link rel="preconnect" href="https://connect.symfony.com">

        <link rel="stylesheet" href="/build/app.88d0e250.css">
        <link rel="stylesheet" href="/build/search.35bd67e5.css">
                
    <link rel="stylesheet" href="/build/doc.f2d98e62.css">


            <style>
        .code-block-caption .headerlink {
            display: none;
        }
        .code-block-caption span {
            font-family: "Droid Sans Mono", Consolas, Menlo, "Ubuntu Mono", monospace;
            font-size: 13px;
            font-variant-ligatures: no-common-ligatures;
            text-rendering: optimizeSpeed;
            background-color: #1e2125;
            color: #fafafa;
            line-height: 1.6;
            padding: 10px 15px;
            border-radius: 3px 3px 0 0;
        }

        .docutils.container {
            padding: 0;
        }

        .backer {
            text-align: center;
            padding-bottom: 0.6em;
        }

        #acknowledgments ul {
            list-style-type: none;
            margin: 2em 0;
            margin-left: 3em;
            padding: 0;
            column-count: 2;
            column-gap: 1.5em;
        }

        .backer p {
            padding: 0;
            font-size: 80%;
            text-align: center;
        }

        .backer img {
            padding: 0;
            margin: 0 auto;
            max-width: 1.1in;
            max-height: 0.6in;
            height: 0.6in;
        }

        main {
            counter-reset: substep -1;
        }
        main .section:not(:first-child) {
            counter-increment: substep;
        }
        main h2::before { content: "0." counter(substep) " "; }

        #individual-backers .github {
            padding: 0 0 0 20px;
            background: url("/images/the-fast-track-book/social/github.svg") no-repeat 0px 0px;
        }

        #individual-backers .twitter {
            padding: 0 0 0 20px;
            background: url("/images/the-fast-track-book/social/twitter.svg") no-repeat 0px 0px;
        }

        #individual-backers .link {
            padding: 0 0 0 20px;
            background: url("/images/the-fast-track-book/social/link.svg") no-repeat 0px 0px;
        }

        .highlight .hll {
            background-color: transparent;
            border-bottom: 1px dotted yellow;
        }

        .book-icon {
            color: var(--gray);
            display: inline-block;
            height: 15px;
            width: 15px;
        }

                </style>
    
        <script>
            window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
            ga('create', 'UA-89393-6', 'auto');
            ga('send', 'pageview');
            ga('set', 'anonymizeIp', true);
        </script>
        <script async src='https://www.google-analytics.com/analytics.js'></script>
            
    <script src="/build/runtime.cc2983e0.js"></script><script src="/build/104.2a46ba74.js"></script><script src="/build/doc.4ddbabdd.js"></script>

        <link rel="shortcut icon" type="image/svg+xml" href="/favicons/favicon.svg">
        <link rel="alternate icon" type="image/png" sizes="16x16" href="/favicons/favicon-16x16.png">
        <link rel="mask-icon" href="/favicons/safari-pinned-tab.svg" color="#5bbad5">
        <link rel="apple-touch-icon" sizes="180x180" href="/favicons/apple-touch-icon.png">
        <link rel="manifest" href="/static/webmanifest.json">
        <meta name="msapplication-config" content="/static/browserconfig.xml" />
        <meta name="theme-color" content="#ffffff">
        <meta name="apple-mobile-web-app-title" content="Symfony">

                <meta name="twitter:site" content="@symfony">

                <meta property="fb:pages" content="211720082183067">

                            <meta property="og:type" content="website">
            <meta property="og:title" content="Symfony 5: The Fast Track (Symfony Docs)">
            <meta property="og:image" content="https://symfony.com/images/opengraph/symfony.png">

                            <meta property="og:description" content="Symfony 5: The Fast Track:   Acknowledgments Step 0: What is it about? Step 1: Checking your Work Environment Step 2: Introducing the Project Step 3: Going from Zero to Production Step 4: Adopting a M...">
                    
                <meta name="msapplication-TileColor" content="#222222">
        <meta name="application-name" content="Symfony">
        <meta name="msapplication-tooltip" content="Official Symfony website">

                <meta name="theme-color" content="#222222">

            
                        <meta name="docsearch:version" content="current" />
    
    <link rel="preconnect" href="https://srv.carbonads.net">
    </head>

    <body>
        <script>
            if (null === localStorage.getItem('themeName') || 'dynamic-theme' === localStorage.getItem('themeName')) {
                document.body.classList.add(matchMedia('(prefers-color-scheme: dark)').matches ? 'dark-theme' : 'light-theme');
                window.matchMedia('(prefers-color-scheme: dark)').addEventListener('change', (e) => {
                    document.body.classList.remove('light-theme', 'dark-theme');
                    document.body.classList.add(e.matches ? 'dark-theme' : 'light-theme');
                });
            } else {
                document.body.classList.add(localStorage.getItem('themeName'));
            }

            document.body.classList.add(
                (navigator.appVersion.indexOf('Win') !== -1) ? 'windows' : (navigator.appVersion.indexOf('Mac') !== -1) ? 'macos' : 'linux'
            );
        </script>

        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"WebSite","name":"Symfony","url":"https:\/\/symfony.com","potentialAction":{"@type":"SearchAction","target":"https:\/\/symfony.com\/search?q={query}","query-input":"required name=query"}}</script>
        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/symfony.com","name":"Symfony","logo":"\/images\/logos\/sf-positive.svg","sameAs":["https:\/\/github.com\/symfony","https:\/\/stackoverflow.com\/questions\/tagged\/symfony","https:\/\/twitter.com\/symfony","https:\/\/www.facebook.com\/SymfonyFramework","https:\/\/www.youtube.com\/user\/SensioLabs"]}</script>
        <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"Event","eventAttendanceMode":"OnlineEventAttendanceMode","eventStatus":"https:\/\/schema.org\/EventScheduled","name":"SymfonyWorld 2021 Winter ","image":"\/images\/conferences\/sfcon.svg","organizer":{"@type":"Organization","name":"Symfony","url":"https:\/\/live.symfony.com"},"location":{"@type":"VirtualLocation","url":"https:\/\/live.symfony.com\/2021-world-winter\/"},"url":"https:\/\/live.symfony.com\/2021-world-winter\/","startDate":"2021-12-09","endDate":"2021-12-10","offers":[{"@type":"Offer","price":79,"priceCurrency":"EUR","url":"https:\/\/live.symfony.com\/2021-world-winter\/registration\/","validFrom":"2021-05-27T00:00:00+02:00","availability":"https:\/\/schema.org\/SoldOut"},{"@type":"Offer","price":119,"priceCurrency":"EUR","url":"https:\/\/live.symfony.com\/2021-world-winter\/registration\/","validFrom":"2021-07-06T00:00:00+02:00","availability":"https:\/\/schema.org\/InStock"},{"@type":"Offer","price":119,"priceCurrency":"EUR","url":"https:\/\/live.symfony.com\/2021-world-winter\/registration\/","validFrom":"2021-12-11T00:00:00+01:00","availability":"https:\/\/schema.org\/InStock"}]}</script>


        <div id="sln"></div>

                <div id="content_wrapper">
            <header>
                <section class="header__top">
                    <div class="container">
                        <div class="header__logo">
                            <a href="/">
                                <img loading="eager" src="/images/logos/header-logo.svg" alt="Symfony" />
                            </a>
                        </div>
                        <div class="hidden-xs">
                            <a href="https://sensiolabs.com" title="SensioLabs, PHP services and software solutions for enterprise and community.">
                                <img loading="eager" height="17" src="/images/pictos/slsponsor.svg" alt="Symfony is sponsored by SensioLabs" />
                            </a>
                        </div>
                        <div class="visible-xs">
                            <button class="header__toggle__menu" type="button" name="toggle" aria-label="Toggle menu" title="Toggle menu">
                                <i class="icon icon--large icon--white"><svg viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1664 1344v128q0 26-19 45t-45 19H192q-26 0-45-19t-19-45v-128q0-26 19-45t45-19h1408q26 0 45 19t19 45zm0-512v128q0 26-19 45t-45 19H192q-26 0-45-19t-19-45V832q0-26 19-45t45-19h1408q26 0 45 19t19 45zm0-512v128q0 26-19 45t-45 19H192q-26 0-45-19t-19-45V320q0-26 19-45t45-19h1408q26 0 45 19t19 45z"/></svg></i>
                            </button>
                        </div>
                    </div>
                </section>

                <section class="header__bottom" data-spy="affix" data-offset-top="90">
                    <div class="container">
                        <nav class="header__nav">
                            <ul>
                                <li class="header__logo--responsive">
                                    <a loading="lazy" href="/"><img alt="Symfony logo" src="/images/logos/sf-positive.svg" /></a>
                                </li>

                                
        <li id="menu-what-is-symfony" >
        <a href="/what-is-symfony">
                        About
        </a>
    </li>
            <li id="menu-learn" class="selected">
        <a href="/doc/current/index.html">
                        Documentation
        </a>
    </li>
            <li id="menu-screencasts" >
        <a href="https://symfonycasts.com/">
                        Screencasts
        </a>
    </li>
            <li id="menu-cloud" >
        <a href="/cloud/">
            <svg focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 640 512"><path fill="currentColor" d="M537.6 226.6c4.1-10.7 6.4-22.4 6.4-34.6 0-53-43-96-96-96-19.7 0-38.1 6-53.3 16.2C367 64.2 315.3 32 256 32c-88.4 0-160 71.6-160 160 0 2.7.1 5.4.2 8.1C40.2 219.8 0 273.2 0 336c0 79.5 64.5 144 144 144h368c70.7 0 128-57.3 128-128 0-61.9-44-113.6-102.4-125.4z"></path></svg>
            Cloud
        </a>
    </li>
            <li id="menu-certification" >
        <a href="https://certification.symfony.com/">
                        Certification
        </a>
    </li>
            <li id="menu-community" >
        <a href="/community">
                        Community
        </a>
    </li>
            <li id="menu-services" >
        <a href="https://sensiolabs.com">
                        Businesses
        </a>
    </li>
            <li id="menu-news" >
        <a href="/blog/">
                        News
        </a>
    </li>
    
                                <li class="hidden-xs header__download">
                                    <a href="/download">Download</a>
                                </li>
                            </ul>
                        </nav>
                    </div>
                </section>
            </header>

                        <div class="container">
                                                            <div class="d-none d-sm-block">
                            <style>
    .conference-banner {
        background: var(--white);
        border-radius: 4px;
        border: 1px solid rgba(0, 0, 0, 0.05);
        box-shadow: 0 4px 6px -1px rgba(0, 0, 0, 0.1), 0 2px 4px -1px rgba(0, 0, 0, 0.06);
        display: flex;
        font-family: -apple-system, BlinkMacSystemFont, Segoe UI, Helvetica, Arial, sans-serif, Apple Color Emoji, Segoe UI Emoji;
        flex: 0;
        flex-wrap: nowrap;
        justify-content: center;
        margin: 15px;
    }
    .conference-container { display: flex; flex-wrap: nowrap; position: relative; flex-basis: 50%; padding: 25px 30px; }
    .conference-container:hover { background: var(--gray-lighter); }
    .conference-logo { height: 36px; margin-right: 10px; margin-top: 3px; width: 36px; }
    .conference-metadata { color: var(--gray-dark); font-size: 14px; }
    .conference-details a { display: block; font-size: 16px; }
    .conference-details a::after { content: ''; position: absolute; top: 0; left: 0; height: 100%; width: 100%; }
    .conference-con a { color: rgb(110, 53, 140); }
    .conference-live a { color: rgb(213, 5, 78); }
    .optional-logo, .optional-conference { display: none !important; }

    .dark-theme .conference-banner { background: var(--gray-lighter); }
    .dark-theme .conference-con a { color: #b794f4 !important; }
    .dark-theme .conference-live a { color: #f687b3 !important; }
    .dark-theme .conference-con .conference-logo { filter: brightness(130%); }
    .dark-theme .conference-live .conference-logo { filter: brightness(105%); }

    @media (min-width: 768px) {
        .conference-banner { margin: 0 45px 30px; }
        .optional-logo { display: block !important; }
        .optional-conference { display: flex !important; }
    }
</style>

<div class="conference-banner">
    <div class="conference-container conference-con">
        <div class="conference-logo optional-logo">
            <svg viewBox="0 0 300 300" xmlns="http://www.w3.org/2000/svg" xmlns:serif="http://www.serif.com/" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path fill="none" d="M0 0h300v300H0z"/><clipPath id="a"><path d="M0 0h300v300H0z"/></clipPath><g serif:id="sfcon-mini" clip-path="url(#a)"><path d="M300 30c0-16.557-13.443-30-30-30H30C13.443 0 0 13.443 0 30v240c0 16.557 13.443 30 30 30h240c16.557 0 30-13.443 30-30V30z" fill="#6e358c"/><path d="M128.958 241.658c0 12.772 9.272 23.356 22.744 23.356 13.384 0 22.656-10.584 22.656-23.356 0-13.559-9.097-23.356-22.656-23.356-13.646 0-22.744 9.797-22.744 23.356zm-5.948-37.177c-4.374-1.925-9.01-2.625-13.734-2.625-18.633 0-32.279 12.51-32.279 31.317 0 19.42 12.859 31.841 32.191 31.841 3.587 0 9.273-.262 13.909-2.187l-.257-4.156a3.1 3.1 0 0 0-3.987-2.776c-2.991.903-6.623 1.421-9.577 1.421-12.684 0-23.006-9.534-23.006-23.881 0-13.733 9.359-23.881 23.443-23.881 3.038 0 5.995.528 8.787 1.582a3.098 3.098 0 0 0 4.178-2.646l.332-4.009zm68.676 21.956c2.45-5.073 8.398-8.135 14.609-8.135 11.547 0 16.708 7.173 16.708 19.157v23.406a3.101 3.101 0 0 1-3.1 3.1h-5.123v-23.094c0-10.41-2.274-15.483-9.447-15.921-9.36 0-13.559 7.523-13.559 18.37v17.545a3.101 3.101 0 0 1-3.1 3.1h-5.123v-44.613h4.861a3.098 3.098 0 0 1 3.099 3.099v3.986h.175zm-53.98 15.221c0-8.485 5.161-16.708 13.996-16.708 8.747 0 13.909 8.223 13.909 16.708 0 7.961-4.287 16.708-13.909 16.708-9.71 0-13.996-8.747-13.996-16.708zm131.721-62.666H30.577c-.355-.024-.449-.012-.794-.109-1.164-.326-2.062-1.423-2.145-2.636a3.007 3.007 0 0 1 1.409-2.719c.344-.209.73-.346 1.129-.401.133-.019.268-.019.401-.028H53c-7.987-7.798-9.293-17.234-7.409-23.363 2.511-8.144 8.984-9.683 15.314-7.741 6.779 2.096 9.432 10.333 7.493 16.657-.216.677-.562 1.805-1.274 3.324-.787 1.738-2.245 3.272-2.869 5.31-.693 2.253.33 4.211 2.099 5.813h27.289c1.97-1.871 3.447-4.169 4.233-6.74 2.444-7.89-2.548-13.398-4.615-15.512l-10.054-10.762c-4.598-5.12-14.713-19.398-9.779-35.432 1.904-6.184 5.91-12.742 11.724-17.083 12.275-9.147 25.621-10.648 38.327-6.995 16.448 4.729 24.347 15.602 34.59 24.005 5.735-16.818 13.683-33.283 25.635-47.176 10.794-12.652 25.297-21.822 41.908-22.39 16.596-.548 29.142 6.974 29.556 18.882.167 5.068-2.74 14.92-12.864 15.261-7.572.262-12.8-4.263-13.036-11.135-.085-2.519.566-4.724 2.292-7.301 1.688-3.304 2.049-3.683 2.006-5.12-.152-4.333-6.692-4.493-8.482-4.409-24.548.811-31.018 33.939-36.263 60.875l-2.569 14.205c14.136 2.067 24.172-.481 29.77-4.102 7.881-5.117-2.205-10.374-.933-16.191 1.288-5.931 6.683-8.794 10.969-8.914 6-.148 10.283 6.077 10.144 12.395-.216 10.444-14.069 24.793-41.783 24.207a96.847 96.847 0 0 1-9.38-.665l-5.228 28.86c-1.387 6.478-2.91 13.66-4.945 21.237h94.561l.401.028c.132.027.265.045.394.082a3.005 3.005 0 0 1 2.09 2.237c.272 1.308-.46 2.759-1.711 3.302-.246.107-.506.18-.773.217-.132.018-.267.018-.401.027zm-127.085-5.893c.469-2.383.942-4.832 1.422-7.35l1.674-10.152c2.723-13.608 5.741-28.784 10.342-43.905-11.162-8.404-17.847-18.821-32.86-22.892-10.29-2.793-16.562-.423-20.973 5.155-5.222 6.604-3.488 15.2 1.557 20.241l8.336 9.223c10.222 11.808 15.809 20.999 13.707 33.359-1.024 6.057-3.949 11.682-8.315 16.321h25.11z" fill="#fefefe"/></g></svg>
        </div>

        <div class="conference-details">
            <a href="https://live.symfony.com/2021-world/">
                SymfonyWorld Online 2021 Summer Edition
            </a>

            <div class="conference-metadata">
                June 17 – 18, 2021
            </div>
        </div>
    </div>

    <div class="conference-container conference-con">
        <div class="conference-logo optional-logo">
            <svg viewBox="0 0 300 300" xmlns="http://www.w3.org/2000/svg" xmlns:serif="http://www.serif.com/" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path fill="none" d="M0 0h300v300H0z"/><clipPath id="a"><path d="M0 0h300v300H0z"/></clipPath><g serif:id="sfcon-mini" clip-path="url(#a)"><path d="M300 30c0-16.557-13.443-30-30-30H30C13.443 0 0 13.443 0 30v240c0 16.557 13.443 30 30 30h240c16.557 0 30-13.443 30-30V30z" fill="#6e358c"/><path d="M128.958 241.658c0 12.772 9.272 23.356 22.744 23.356 13.384 0 22.656-10.584 22.656-23.356 0-13.559-9.097-23.356-22.656-23.356-13.646 0-22.744 9.797-22.744 23.356zm-5.948-37.177c-4.374-1.925-9.01-2.625-13.734-2.625-18.633 0-32.279 12.51-32.279 31.317 0 19.42 12.859 31.841 32.191 31.841 3.587 0 9.273-.262 13.909-2.187l-.257-4.156a3.1 3.1 0 0 0-3.987-2.776c-2.991.903-6.623 1.421-9.577 1.421-12.684 0-23.006-9.534-23.006-23.881 0-13.733 9.359-23.881 23.443-23.881 3.038 0 5.995.528 8.787 1.582a3.098 3.098 0 0 0 4.178-2.646l.332-4.009zm68.676 21.956c2.45-5.073 8.398-8.135 14.609-8.135 11.547 0 16.708 7.173 16.708 19.157v23.406a3.101 3.101 0 0 1-3.1 3.1h-5.123v-23.094c0-10.41-2.274-15.483-9.447-15.921-9.36 0-13.559 7.523-13.559 18.37v17.545a3.101 3.101 0 0 1-3.1 3.1h-5.123v-44.613h4.861a3.098 3.098 0 0 1 3.099 3.099v3.986h.175zm-53.98 15.221c0-8.485 5.161-16.708 13.996-16.708 8.747 0 13.909 8.223 13.909 16.708 0 7.961-4.287 16.708-13.909 16.708-9.71 0-13.996-8.747-13.996-16.708zm131.721-62.666H30.577c-.355-.024-.449-.012-.794-.109-1.164-.326-2.062-1.423-2.145-2.636a3.007 3.007 0 0 1 1.409-2.719c.344-.209.73-.346 1.129-.401.133-.019.268-.019.401-.028H53c-7.987-7.798-9.293-17.234-7.409-23.363 2.511-8.144 8.984-9.683 15.314-7.741 6.779 2.096 9.432 10.333 7.493 16.657-.216.677-.562 1.805-1.274 3.324-.787 1.738-2.245 3.272-2.869 5.31-.693 2.253.33 4.211 2.099 5.813h27.289c1.97-1.871 3.447-4.169 4.233-6.74 2.444-7.89-2.548-13.398-4.615-15.512l-10.054-10.762c-4.598-5.12-14.713-19.398-9.779-35.432 1.904-6.184 5.91-12.742 11.724-17.083 12.275-9.147 25.621-10.648 38.327-6.995 16.448 4.729 24.347 15.602 34.59 24.005 5.735-16.818 13.683-33.283 25.635-47.176 10.794-12.652 25.297-21.822 41.908-22.39 16.596-.548 29.142 6.974 29.556 18.882.167 5.068-2.74 14.92-12.864 15.261-7.572.262-12.8-4.263-13.036-11.135-.085-2.519.566-4.724 2.292-7.301 1.688-3.304 2.049-3.683 2.006-5.12-.152-4.333-6.692-4.493-8.482-4.409-24.548.811-31.018 33.939-36.263 60.875l-2.569 14.205c14.136 2.067 24.172-.481 29.77-4.102 7.881-5.117-2.205-10.374-.933-16.191 1.288-5.931 6.683-8.794 10.969-8.914 6-.148 10.283 6.077 10.144 12.395-.216 10.444-14.069 24.793-41.783 24.207a96.847 96.847 0 0 1-9.38-.665l-5.228 28.86c-1.387 6.478-2.91 13.66-4.945 21.237h94.561l.401.028c.132.027.265.045.394.082a3.005 3.005 0 0 1 2.09 2.237c.272 1.308-.46 2.759-1.711 3.302-.246.107-.506.18-.773.217-.132.018-.267.018-.401.027zm-127.085-5.893c.469-2.383.942-4.832 1.422-7.35l1.674-10.152c2.723-13.608 5.741-28.784 10.342-43.905-11.162-8.404-17.847-18.821-32.86-22.892-10.29-2.793-16.562-.423-20.973 5.155-5.222 6.604-3.488 15.2 1.557 20.241l8.336 9.223c10.222 11.808 15.809 20.999 13.707 33.359-1.024 6.057-3.949 11.682-8.315 16.321h25.11z" fill="#fefefe"/></g></svg>
        </div>

        <div class="conference-details">
            <a href="https://live.symfony.com/2021-world-winter/">
                SymfonyWorld Online 2021 Winter Edition
            </a>

            <div class="conference-metadata">
                December 9 – 10, 2021
            </div>
        </div>
    </div>
</div>

                        </div>
                    
                    <div class="row">
                        <aside class="col-sm-3">
                                                                        <div class="text-center">
            <a href="/book"><img src="/images/the-fast-track-book/covers/en.png" /></a>
        </div>
        <div class="flex-1 m-t-10 text-center small">
                            <span class="book-icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M128 152v-32c0-4.4 3.6-8 8-8h208c4.4 0 8 3.6 8 8v32c0 4.4-3.6 8-8 8H136c-4.4 0-8-3.6-8-8zm8 88h208c4.4 0 8-3.6 8-8v-32c0-4.4-3.6-8-8-8H136c-4.4 0-8 3.6-8 8v32c0 4.4 3.6 8 8 8zm299.1 159.7c-4.2 13-4.2 51.6 0 64.6 7.3 1.4 12.9 7.9 12.9 15.7v16c0 8.8-7.2 16-16 16H80c-44.2 0-80-35.8-80-80V80C0 35.8 35.8 0 80 0h352c8.8 0 16 7.2 16 16v368c0 7.8-5.5 14.2-12.9 15.7zm-41.1.3H80c-17.6 0-32 14.4-32 32 0 17.7 14.3 32 32 32h314c-2.7-17.3-2.7-46.7 0-64zm6-352H80c-17.7 0-32 14.3-32 32v278.7c9.8-4.3 20.6-6.7 32-6.7h320V48z" class=""></path></svg>
</span>
                <a class="m-r-10" href="https://www.amazon.com/Symfony-5-Track-Fabien-Potencier/dp/2918390372/">Printed</a>
                                        <span class="book-icon"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 384 512"><path fill="currentColor" d="M369.9 97.9L286 14C277 5 264.8-.1 252.1-.1H48C21.5 0 0 21.5 0 48v416c0 26.5 21.5 48 48 48h288c26.5 0 48-21.5 48-48V131.9c0-12.7-5.1-25-14.1-34zM332.1 128H256V51.9l76.1 76.1zM48 464V48h160v104c0 13.3 10.7 24 24 24h104v288H48zm250.2-143.7c-12.2-12-47-8.7-64.4-6.5-17.2-10.5-28.7-25-36.8-46.3 3.9-16.1 10.1-40.6 5.4-56-4.2-26.2-37.8-23.6-42.6-5.9-4.4 16.1-.4 38.5 7 67.1-10 23.9-24.9 56-35.4 74.4-20 10.3-47 26.2-51 46.2-3.3 15.8 26 55.2 76.1-31.2 22.4-7.4 46.8-16.5 68.4-20.1 18.9 10.2 41 17 55.8 17 25.5 0 28-28.2 17.5-38.7zm-198.1 77.8c5.1-13.7 24.5-29.5 30.4-35-19 30.3-30.4 35.7-30.4 35zm81.6-190.6c7.4 0 6.7 32.1 1.8 40.8-4.4-13.9-4.3-40.8-1.8-40.8zm-24.4 136.6c9.7-16.9 18-37 24.7-54.7 8.3 15.1 18.9 27.2 30.1 35.5-20.8 4.3-38.9 13.1-54.8 19.2zm131.6-5s-5 6-37.3-7.8c35.1-2.6 40.9 5.4 37.3 7.8z"></path></svg>
</span>
                <a class="m-r-10" href="https://leanpub.com/symfony5-the-fast-track">PDF</a>
                    </div>
        <div class="m-t-30">
            <div class="m-b-30">
                <div class="d-flex flex-nowrap" style="align-items: center; justify-content: center;">
                    <div style="width: 120px;">
                        <a href="https://blackfire.io" target="_blank">
                            <img src="/images/the-fast-track-book/logos/blackfire.svg">
                        </a>
                    </div>

                    <div style="width: 120px;">
                        <a href="https://packagist.com/" target="_blank">
                            <img src="/images/the-fast-track-book/logos/packagist.svg">
                        </a>
                    </div>

                    <div style="width: 120px">
                        <a href="https://darkmira.com/" target="_blank">
                            <img src="/images/the-fast-track-book/logos/darkmira.svg">
                        </a>
                    </div>
                </div>

                <div class="text-center">
                    <a href="/book">see all backers</a>
                </div>
            </div>
        </div>
    
                                                                



<div class="ads">
    <div class="ad-carbonads ad-hidden" style="min-height: 210px;">
        <script defer type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CKYILK3J&placement=symfonycom" id="_carbonads_js"></script>
    </div>

                        
        <div class="ad-symfony ad-visible" style="font-size: 14px; font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif; line-height: 1.5; margin-bottom: 1.5em; padding-right: 1em;">
            <a href="https://certification.symfony.com/?utm_source=ad&amp;utm_medium=banner&amp;utm_campaign=certification&amp;utm_content=symfonyexpertise" data-tracked data-category="Ads" data-action="sidebar" data-label="certif_insight" style="margin-bottom: 8px">
                <img loading="lazy" src="/images/network/sf5certif_01.png" height="100" width="130" style="margin-bottom: 8px" class="img-responsive" alt="Show your Symfony expertise" />
            </a>
            <p class="ad-text" style="margin-bottom: 0">
                <a href="https://certification.symfony.com/?utm_source=ad&amp;utm_medium=banner&amp;utm_campaign=certification&amp;utm_content=symfonyexpertise" style="color: inherit; margin-bottom: 20px; text-decoration: none">Show your Symfony expertise</a>
            </p>
        </div>
                    
        <div class="ad-symfony ad-hidden" style="font-size: 14px; font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif; line-height: 1.5; margin-bottom: 1.5em; padding-right: 1em;">
            <a href="https://symfony.com/cloud/?utm_source=ad&amp;utm_medium=banner&amp;utm_campaign=cloud&amp;utm_content=batteries" data-tracked data-category="Ads" data-action="sidebar" data-label="cloud" style="margin-bottom: 8px">
                <img loading="lazy" src="/images/network/sfcloud_02.png" height="100" width="130" style="margin-bottom: 8px" class="img-responsive" alt="Batteries included: just code" />
            </a>
            <p class="ad-text" style="margin-bottom: 0">
                <a href="https://symfony.com/cloud/?utm_source=ad&amp;utm_medium=banner&amp;utm_campaign=cloud&amp;utm_content=batteries" style="color: inherit; margin-bottom: 20px; text-decoration: none">Batteries included: just code</a>
            </p>
        </div>
    </div>

                                                    </aside>

                        <main class="col-sm-9">
                                                                                                                                    <ol class="breadcrumb">
                                                                                    <li class="">
                                                                                                <a href="/">Home</a>
                                            </li>
                                                                                    <li class="">
                                                                                                <a href="/doc/current/index.html">Documentation</a>
                                            </li>
                                                                                    <li class="">
                                                                                                <a href="/book">Symfony5: The Fast Track</a>
                                            </li>
                                                                                    <li class="">
                                                                                                <a href="/doc/current/the-fast-track/en/index.html">English</a>
                                            </li>
                                                                            </ol>

                                    <script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"\/doc\/current\/index.html","name":"Documentation"}},{"@type":"ListItem","position":3,"item":{"@id":"\/book","name":"Symfony5: The Fast Track"}},{"@type":"ListItem","position":4,"item":{"@id":"\/doc\/current\/the-fast-track\/en\/index.html","name":"English"}}]}</script>
                                
                                    
    
    
                                                                    <h1>Symfony 5: The Fast Track</h1>
                                
                                    
    <div class="page ">
        
        
        <div class="doc__tools clearfix">
                                <div class="doc__version">
        <div class="version__current">
            5.2 version
            <i class="pull-right icon icon--small icon--white"><svg viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1408 704q0 26-19 45l-448 448q-19 19-45 19t-45-19L403 749q-19-19-19-45t19-45 45-19h896q26 0 45 19t19 45z"/></svg></i>
        </div>

        <div class="version__all">
                            <strong>Maintained</strong>
                <div class="version__list">
                                            <a href="/doc/5.2/index.html">
                            5.2
                                                            <small>current</small>
                                                    </a>
                                    </div>
            
                            <strong>Unmaintained</strong>
                <div class="version__list">
                                            <a href="/doc/5.0/index.html">5.0</a>
                                    </div>
                    </div>
    </div>

            
            
                    </div>

        
        <div class="section" id="symfony-5-the-fast-track">
<h1>Symfony 5: The Fast Track<a class="headerlink" href="#symfony-5-the-fast-track" title="Permalink to this headline">¶</a></h1>
<div class="toctree-wrapper compound">
<ul>
<li class="toctree-l1"><a class="reference internal" href="preface.html">Acknowledgments</a></li>
<li class="toctree-l1"><a class="reference internal" href="0-intro.html">Step 0: What is it about?</a></li>
<li class="toctree-l1"><a class="reference internal" href="1-tools.html">Step 1: Checking your Work Environment</a></li>
<li class="toctree-l1"><a class="reference internal" href="2-project.html">Step 2: Introducing the Project</a></li>
<li class="toctree-l1"><a class="reference internal" href="3-zero.html">Step 3: Going from Zero to Production</a></li>
<li class="toctree-l1"><a class="reference internal" href="4-methodology.html">Step 4: Adopting a Methodology</a></li>
<li class="toctree-l1"><a class="reference internal" href="5-debug.html">Step 5: Troubleshooting Problems</a></li>
<li class="toctree-l1"><a class="reference internal" href="6-controller.html">Step 6: Creating a Controller</a></li>
<li class="toctree-l1"><a class="reference internal" href="7-database.html">Step 7: Setting up a Database</a></li>
<li class="toctree-l1"><a class="reference internal" href="8-doctrine.html">Step 8: Describing the Data Structure</a></li>
<li class="toctree-l1"><a class="reference internal" href="9-backend.html">Step 9: Setting up an Admin Backend</a></li>
<li class="toctree-l1"><a class="reference internal" href="10-twig.html">Step 10: Building the User Interface</a></li>
<li class="toctree-l1"><a class="reference internal" href="11-branch.html">Step 11: Branching the Code</a></li>
<li class="toctree-l1"><a class="reference internal" href="12-event.html">Step 12: Listening to Events</a></li>
<li class="toctree-l1"><a class="reference internal" href="13-lifecycle.html">Step 13: Managing the Lifecycle of Doctrine Objects</a></li>
<li class="toctree-l1"><a class="reference internal" href="14-form.html">Step 14: Accepting Feedback with Forms</a></li>
<li class="toctree-l1"><a class="reference internal" href="15-security.html">Step 15: Securing the Admin Backend</a></li>
<li class="toctree-l1"><a class="reference internal" href="16-spam.html">Step 16: Preventing Spam with an API</a></li>
<li class="toctree-l1"><a class="reference internal" href="17-tests.html">Step 17: Testing</a></li>
<li class="toctree-l1"><a class="reference internal" href="18-async.html">Step 18: Going Async</a></li>
<li class="toctree-l1"><a class="reference internal" href="19-workflow.html">Step 19: Making Decisions with a Workflow</a></li>
<li class="toctree-l1"><a class="reference internal" href="20-emails.html">Step 20: Emailing Admins</a></li>
<li class="toctree-l1"><a class="reference internal" href="21-cache.html">Step 21: Caching for Performance</a></li>
<li class="toctree-l1"><a class="reference internal" href="22-encore.html">Step 22: Styling the User Interface with Webpack</a></li>
<li class="toctree-l1"><a class="reference internal" href="23-imagine.html">Step 23: Resizing Images</a></li>
<li class="toctree-l1"><a class="reference internal" href="24-cron.html">Step 24: Running Crons</a></li>
<li class="toctree-l1"><a class="reference internal" href="25-notifier.html">Step 25: Notifying by all Means</a></li>
<li class="toctree-l1"><a class="reference internal" href="26-api.html">Step 26: Exposing an API with API Platform</a></li>
<li class="toctree-l1"><a class="reference internal" href="27-spa.html">Step 27: Building an SPA</a></li>
<li class="toctree-l1"><a class="reference internal" href="28-intl.html">Step 28: Localizing an Application</a></li>
<li class="toctree-l1"><a class="reference internal" href="29-performance.html">Step 29: Managing Performance</a></li>
<li class="toctree-l1"><a class="reference internal" href="30-internals.html">Step 30: Discovering Symfony Internals</a></li>
<li class="toctree-l1"><a class="reference internal" href="31-redis.html">Step 31: Using Redis to Store Sessions</a></li>
<li class="toctree-l1"><a class="reference internal" href="32-rabbitmq.html">Step 32: Using RabbitMQ as a Message Broker</a></li>
<li class="toctree-l1"><a class="reference internal" href="next.html">What’s Next?</a></li>
</ul>
</div>
</div>


                    <hr class="m-t-30">

            <ul class="pager m-b-45">
                
                                    <li class="text-right m-t-0">
                        <a class="text-large" title="Acknowledgments" href="preface.html">Next &raquo;</a>
                        <span class="block text-muted m-t-5">Acknowledgments</span>
                    </li>
                            </ul>
            </div>

            <div class="m-t-30">
    <p class="text-muted">
        This work, including the code samples, is licensed under a
                    <a rel="license" href="https://creativecommons.org/licenses/by-nc-sa/4.0/">Creative Commons BY-NC-SA 4.0</a>
                license.
    </p>
</div>

                                                        </main>
                    </div>
                            </div>
            
                            <footer>
                                            <section class="promos">
    <div class="container">
        <div class="row">
            <div class="col-sm-4 m-b-30">
                <h4 class="m-b-15">Latest from the Symfony Blog</h4>

                <ul class="list--unstyled list--border m-b-30">
                                            <li>
                            <a href="/blog/a-week-of-symfony-763-9-15-august-2021">A Week of Symfony #763 (9-15 August 2021)</a>
                            <span class="metadata block m-b-0">August 15, 2021</span>
                        </li>
                                            <li>
                            <a href="/blog/a-week-of-symfony-762-2-8-august-2021">A Week of Symfony #762 (2-8 August 2021)</a>
                            <span class="metadata block m-b-0">August 8, 2021</span>
                        </li>
                                    </ul>
            </div>

            <div class="col-sm-4 m-b-30">
                                    <h4 class="m-b-15">They Help Us Make Symfony</h4>
                                        <div class="box box--small box--white box--shadow">
                            <div class="d-flex ">
        <img loading="lazy" class="m-r-15 avatar avatar--large " width="40" height="40"
             alt="Avatar of Pascal Montoya, a Symfony contributor"
             src="https://www.gravatar.com/avatar/43a4c3b98cbd2f2dcfccdd0fec05eb92?size=80&rating=g&default=retro">

        <div class="">
            
            Thanks <strong>
                            <span class="">Pascal Montoya</span>
            
            </strong> for being a <a class="link-muted" title="List of all Symfony contributors" href="/contributors">Symfony contributor</a>.
            <small class="block m-t-5 text-muted">
                                                
                                    <strong title="7 commits">7</strong> commits
                                &middot; <strong title="155 lines of code/doc changed">155</strong> lines
            </small>
        </div>
    </div>

                    </div>
                            </div>

            <div class="col-sm-4 m-b-30">
                <h4 class="m-b-15">Get Involved in the Community</h4>
                <p>
                    A passionate group of over 600,000 developers from more than
                    120 countries, all committed to helping PHP surpass the impossible.
                </p>

                <p class="m-b-5">
                    <a class="read-more" href="/community">Getting involved</a>
                </p>
            </div>
        </div>
    </div>
</section>

                    
                    <section>
                        <div class="container">
                            <p class="m-t-0 m-b-15 text-small">
                                <b>Symfony</b>&trade; is a trademark of Symfony SAS. <a href="/trademark">All rights reserved</a>.
                            </p>

                            <ul class="sitemap ">
    <li>
        <h6><a href="/what-is-symfony">What is Symfony?</a></h6>
        <ul class="list_menu_footer list-unstyled">
            
        <li id="menu-at-a-glance" >
        <a href="/at-a-glance">
                        Symfony at a Glance
        </a>
    </li>
            <li id="menu-components" >
        <a href="/components">
                        Symfony Components
        </a>
    </li>
            <li id="menu-case-studies" >
        <a href="/blog/category/case-studies">
                        Case Studies
        </a>
    </li>
            <li id="menu-symfony-releases" >
        <a href="/releases">
                        Symfony Releases
        </a>
    </li>
            <li id="menu-security-policy" >
        <a href="/doc/current/contributing/code/security.html">
                        Security Policy
        </a>
    </li>
            <li id="menu-logo" >
        <a href="/logo">
                        Logo &amp; Screenshots
        </a>
    </li>
            <li id="menu-license" >
        <a href="/license">
                        Trademark &amp; Licenses
        </a>
    </li>
            <li id="menu-symfony-legacy" >
        <a href="/legacy">
                        symfony1 Legacy
        </a>
    </li>
    
        </ul>
    </li>

    <li>
        <h6><a href="/doc/current/index.html">Learn Symfony</a></h6>
        <ul class="list_menu_footer list-unstyled">
            
    


    <li class="">
        <a href="/doc/5.2/setup.html">Getting Started</a>
    </li>
    <li class="">
        <a href="/doc/5.2/components/index.html">Components</a>
    </li>
    <li class="">
        <a href="/doc/5.2/best_practices/index.html">Best Practices</a>
    </li>
    <li class="">
        <a href="/doc/bundles/">Bundles</a>
    </li>
    <li class="">
        <a href="/doc/5.2/reference/index.html">Reference</a>
    </li>
    <li class="">
        <a href="https://training.sensiolabs.com/en/">Training</a>
    </li>
    <li class="">
        <a href="https://university.sensiolabs.com/e-learning-platform">eLearning Platform</a>
    </li>
    <li class="">
        <a href="https://certification.symfony.com/">Certification</a>
    </li>

        </ul>
    </li>

    <li>
        <h6><a href="https://symfonycasts.com">Screencasts</a></h6>
        <ul class="list_menu_footer list-unstyled">
            <li><a href="https://symfonycasts.com/tracks/symfony">Learn Symfony</a></li>
            <li><a href="https://symfonycasts.com/tracks/php">Learn PHP</a></li>
            <li><a href="https://symfonycasts.com/tracks/javascript">Learn JavaScript</a></li>
            <li><a href="https://symfonycasts.com/tracks/drupal">Learn Drupal</a></li>
            <li><a href="https://symfonycasts.com/tracks/rest">Learn RESTful APIs</a></li>
        </ul>
    </li>

    <li>
        <h6><a href="/community">Community</a></h6>
        <ul class="list_menu_footer list-unstyled">
            
        <li id="menu-symfony-connect" >
        <a href="https://connect.symfony.com/">
                        SymfonyConnect
        </a>
    </li>
            <li id="menu-support" >
        <a href="/support">
                        Support
        </a>
    </li>
            <li id="menu-how-to-be-involved" >
        <a href="/doc/current/contributing/index.html">
                        How to be Involved
        </a>
    </li>
            <li id="menu-code-of-conduct" >
        <a href="/doc/current/contributing/code_of_conduct/code_of_conduct.html">
                        Code of Conduct
        </a>
    </li>
            <li id="menu-events" >
        <a href="/events/">
                        Events &amp; Meetups
        </a>
    </li>
            <li id="menu-projects" >
        <a href="/projects">
                        Projects using Symfony
        </a>
    </li>
            <li id="menu-downloads_stats" >
        <a href="/stats/downloads">
                        Downloads Stats
        </a>
    </li>
            <li id="menu-contributors" >
        <a href="/contributors">
                        Contributors
        </a>
    </li>
            <li id="menu-backers" >
        <a href="/backers">
                        Backers
        </a>
    </li>
    
        </ul>
    </li>

    <li>
        <h6><a href="/blog/">Blog</a></h6>
        <ul class="list_menu_footer list-unstyled">
            <li>
    <a href="/events">Events &amp; Meetups</a>
</li>


    <li class="">
        <a href="/blog/category/a-week-of-symfony">A week of symfony</a>
    </li>
    <li class="">
        <a href="/blog/category/case-studies">Case studies</a>
    </li>
    <li class="">
        <a href="/blog/category/cloud">Cloud</a>
    </li>
    <li class="">
        <a href="/blog/category/community">Community</a>
    </li>
    <li class="">
        <a href="/blog/category/conferences">Conferences</a>
    </li>
    <li class="">
        <a href="/blog/category/diversity">Diversity</a>
    </li>
    <li class="">
        <a href="/blog/category/documentation">Documentation</a>
    </li>
    <li class="">
        <a href="/blog/category/living-on-the-edge">Living on the edge</a>
    </li>
    <li class="">
        <a href="/blog/category/releases">Releases</a>
    </li>
    <li class="">
        <a href="/blog/category/security-advisories">Security Advisories</a>
    </li>
    <li class="">
        <a href="/blog/category/symfony-insight">SymfonyInsight</a>
    </li>
    <li class="">
        <a href="/blog/category/twig">Twig</a>
    </li>

<li style="margin-bottom: 20px">
    <a href="https://blog.sensiolabs.com/">SensioLabs</a>
</li>

        </ul>
    </li>

    <li>
        <h6><a href="https://sensiolabs.com">Services</a></h6>
        <ul class="list_menu_footer list-unstyled">
            <li><a href="https://sensiolabs.com">Our services</a></li>
            <li><a href="https://training.sensiolabs.com/en">Train developers</a></li>
            <li><a href="https://insight.symfony.com/">Manage your project quality</a></li>
            <li><a href="https://blackfire.io/?utm_source=symfony&utm_medium=symfonycom_footer&utm_campaign=profiler">Improve your project performance</a></li>
            <li><a href="/cloud/">Host Symfony projects</a></li>
        </ul>

        <h6 class="m-t-30"><a href="/about">About</a></h6>
        <ul class="list_menu_footer list-unstyled">
            
        <li id="menu-sensiolabs" >
        <a href="https://sensiolabs.com/en/join_us/join_us.html">
                        SensioLabs
        </a>
    </li>
            <li id="menu-careers" >
        <a href="https://sensiolabs.com/en/join_us/our_job_offers.html">
                        Careers
        </a>
    </li>
            <li id="menu-support" >
        <a href="/support">
                        Support
        </a>
    </li>
            <li id="menu-cloud_tos" >
        <a href="/cloud/tos">
                        Cloud TOS
        </a>
    </li>
    
        </ul>

                    <div class="m-t-30">
                <h6><span>Deployed on</span></h6>
                <a href="/cloud/" class="block m-t-10" title="SymfonyCloud, a Platform-as-a-Service built and optimized for Symfony developers">
                    <svg width="170" viewBox="0 0 1830 300" xmlns="http://www.w3.org/2000/svg" xmlns:serif="http://www.serif.com/" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path fill="none" d="M0 0h1830v300H0z"/><g serif:id="sfcloud-large-white"><path d="M300 30c0-16.557-13.443-30-30-30H30C13.443 0 0 13.443 0 30v240c0 16.557 13.443 30 30 30h240c16.557 0 30-13.443 30-30V30z" fill="#fff"/><path d="M225.973 38.889c-16.691.571-31.263 9.785-42.109 22.497-12.009 13.961-19.996 30.505-25.759 47.404-10.292-8.444-18.229-19.369-34.756-24.121-12.768-3.671-26.177-2.162-38.512 7.029-5.842 4.362-9.867 10.951-11.78 17.165-4.957 16.111 5.206 30.458 9.826 35.603l10.102 10.814c2.077 2.124 7.093 7.658 4.638 15.586-2.64 8.634-13.041 14.206-23.708 10.931-4.767-1.462-11.611-5.01-10.075-9.999.627-2.048 2.092-3.589 2.883-5.336.714-1.526 1.063-2.66 1.28-3.339 1.948-6.355-.718-14.632-7.53-16.738-6.36-1.951-12.864-.405-15.387 7.778-2.859 9.299 1.591 26.178 25.434 33.523 27.932 8.596 51.555-6.619 54.906-26.447 2.113-12.42-3.501-21.654-13.772-33.52l-8.377-9.267c-5.068-5.065-6.811-13.702-1.564-20.338 4.433-5.605 10.735-7.987 21.074-5.18 15.085 4.09 21.803 14.558 33.018 23.002-4.623 15.193-7.655 30.443-10.392 44.116l-1.681 10.202c-8.016 42.045-14.139 65.143-30.045 78.4-3.208 2.283-7.788 5.696-14.69 5.939-3.627.111-4.796-2.385-4.846-3.475-.082-2.534 2.057-3.7 3.478-4.84 2.13-1.163 5.344-3.085 5.124-9.246-.232-7.281-6.261-13.591-14.98-13.301-6.528.22-16.48 6.357-16.102 17.608.384 11.622 11.212 20.329 27.543 19.776 8.728-.293 28.222-3.844 47.427-26.673 22.357-26.18 28.609-56.181 33.311-78.143l5.253-28.999c2.913.352 6.033.589 9.426.668 27.847.589 41.766-13.828 41.983-24.323.141-6.349-4.163-12.604-10.192-12.454-4.307.12-9.727 2.997-11.022 8.956-1.278 5.845 8.856 11.127.937 16.269-5.625 3.639-15.709 6.199-29.913 4.122l2.581-14.274c5.271-27.065 11.772-60.353 36.438-61.167 1.799-.085 8.37.076 8.523 4.429.044 1.445-.32 1.826-2.016 5.145-1.734 2.59-2.388 4.805-2.303 7.336.238 6.906 5.491 11.453 13.099 11.189 10.172-.343 13.093-10.242 12.926-15.334-.416-11.965-13.022-19.524-29.699-18.973z" fill="#18171b" fill-rule="nonzero"/><path d="M612.349 103.388l-46.356 128.475c-8.638 24.154-17.761 52.023-48.319 52.023-7.401 0-11.61-.991-15.792-1.728l.62-8.025c.894-5.684 4.879-9.376 10.163-9.089.507.04 1.03.09 1.542.09 20.716 0 27.621-28.594 27.621-31.059 0-2.707-2.96-9.117-4.446-13.315L494.73 103.388h16.162c.04 0 .068.028.124.028 4.908 0 9.652 3.383 11.689 7.947l31.2 96.082h.495l31.898-96.133c2.06-4.541 6.793-7.896 11.678-7.896.056 0 .067-.028.123-.028h14.25zm686.164 0l-46.356 128.475c-8.638 24.154-17.772 52.023-48.336 52.023-7.389 0-11.599-.991-15.791-1.728l.63-8.025c.895-5.684 4.885-9.376 10.152-9.089.524.04 1.036.09 1.542.09 20.716 0 27.632-28.594 27.632-31.059 0-2.707-2.971-9.117-4.457-13.315l-42.652-117.372h16.163c.039 0 .067.028.112.028 4.907 0 9.668 3.383 11.7 7.947l31.2 96.082h.507l31.886-96.133c2.049-4.541 6.793-7.896 11.678-7.896.056 0 .084-.028.123-.028h14.267zm-324.415-2.954c38.223 0 63.846 27.621 63.846 65.833 0 36-26.118 65.827-63.846 65.827-37.965 0-64.1-29.827-64.1-65.827 0-38.212 25.623-65.833 64.1-65.833zm462.491-39.078c-8.823-4.656-29.165-6.372-39.214-6.372-52.939 0-86.271 36.518-86.271 88.477 0 52.939 32.352 88.476 86.271 88.476 10.784 0 29.901-1.715 39.214-7.352v-.001a11.024 11.024 0 0 0-13.549-9.992c-8.629 2.026-18.376 2.64-25.665 2.64-45.096 0-69.36-30.636-69.36-73.771 0-42.4 24.999-73.772 69.36-73.772 7.51 0 16.362.671 24.578 2.553a11.942 11.942 0 0 0 14.631-10.884l.005-.002zm46.344 105.143c0 34.067 17.891 65.438 58.331 65.438 40.439 0 58.331-31.371 58.331-65.438 0-34.067-17.892-65.438-58.331-65.438-40.44 0-58.331 31.371-58.331 65.438zm227.107-62.497h-2.737a12.703 12.703 0 0 0-12.703 12.704v56.41c0 20.833-8.824 45.587-37.009 45.587-21.322 0-29.655-15.196-29.655-38.724v-63.273a12.704 12.704 0 0 0-12.704-12.704h-2.737V183.9c0 27.45 11.764 48.037 42.645 48.037 25.98 0 35.293-13.97 40.44-25.244h.49v22.303h1.401a12.704 12.704 0 0 0 12.704-12.719l-.135-112.275zm104.029 21.077V45.181h2.736a12.7 12.7 0 0 1 8.983 3.721 12.7 12.7 0 0 1 3.721 8.983v158.408a12.703 12.703 0 0 1-12.704 12.703h-2.736v-19.852h-.491c-8.333 15.931-21.077 22.793-38.968 22.793-34.313 0-51.469-28.43-51.469-65.438 0-37.989 14.705-65.438 51.469-65.438 24.508 0 36.763 17.891 38.968 24.018h.491zM424.419 231.835h-.147c-11.733 0-23.411-3.213-34.801-6.894l.697-6.781c.665-6.061 4.925-10.642 10.125-9.792 8.284 2.616 18.115 4.879 27.182 4.907 15.487-.028 37.964-8.622 38.077-31.909-.18-22.325-21.256-29.956-40.486-39.203-19.601-9.488-37.824-19.978-37.88-47.025.084-30.935 24.002-47.149 56.232-47.346 8.841 0 18.993 1.221 28.707 3.636l-.428 7.603c-.63 5.233-5.076 9.387-10.383 8.998-.084 0-.084.079-.141.079-5.031-1.103-10.175-1.739-16.613-1.739-.028 0-.095 0-.152.011-14.829-.022-34.042 5.476-34.115 26.406.372 19.702 21.307 26.354 40.458 36.146 19.517 9.916 37.863 22.027 37.919 50.869-.107 37.374-28.155 51.775-64.251 52.034zm647.074-2.696h-12.736V103.388h11.801c.04 0 .051.028.107.028 5.808 0 10.513 4.705 10.513 10.53 0 .022.022.022.022.034v9.398h.484c6.917-14.306 23.671-22.944 41.184-22.944 32.545 0 47.098 20.226 47.098 54.003v64.668c-.264 5.577-4.817 10.029-10.456 10.029-.028 0-.028.005-.039.005h-12.697v-65.09c0-29.348-6.381-43.643-26.619-44.869-26.382 0-38.223 21.205-38.223 51.775v48.499c-.428 5.408-4.896 9.68-10.411 9.68-.027 0-.028.005-.028.005zm-208.378 0h-12.763V122.14h-19.151c-.028 0-.051-.028-.079-.028-5.284 0-9.618-3.895-10.372-8.954v-9.77h29.602v-9.983c0-30.581 7.895-50.554 42.157-50.554 5.903 0 10.856.737 15.532 1.48l-.399 7.592c-.321 5.538-4.924 10.051-10.468 9.646-.056 0-.045.062-.084.062-.383-.017-.771-.045-1.142-.045-19.956 0-22.421 12.836-22.421 29.843v11.959h33.288v8.751c-.259 5.454-4.649 9.821-10.108 10.001h-23.18v97.905c-.715 5.11-5.06 9.089-10.372 9.089-.028 0-.011.005-.04.005zm-219.48 0h-12.556V103.388h11.087c.039 0 .068.028.113.028 5.774 0 10.422 4.649 10.506 10.4v7.829h.496c8.858-14.554 21.441-21.211 39.928-21.211 14.554 0 29.096 7.4 35.764 24.413 8.628-17.992 27.61-24.413 38.944-24.413 32.072 0 43.643 20.715 43.643 48.089v72.411c-1.058 4.699-5.228 8.2-10.231 8.2-.017 0-.017.005-.028.005h-12.905V154.19c0-15.538-3.714-35.01-22.449-35.01-23.658 0-33.04 23.18-33.04 46.603v53.784c-.495 5.357-4.924 9.567-10.4 9.567-.028 0-.028.005-.039.005h-12.724V154.19c0-15.538-3.715-35.01-22.449-35.01-23.671 0-33.041 23.18-33.041 46.603V218.3c-.028.102-.078.164-.078.321 0 5.802-4.705 10.513-10.513 10.513-.011 0-.027.005-.028.005zm810.039-.143h2.737a12.706 12.706 0 0 0 12.704-12.703V57.885a12.704 12.704 0 0 0-12.704-12.704h-2.737v183.815zm46.166-62.497c0-28.92 14.46-52.204 41.42-52.204 26.959 0 41.42 23.284 41.42 52.204s-14.461 52.204-41.42 52.204c-26.96 0-41.42-23.284-41.42-52.204zm240.208 0c0-24.264 7.598-52.204 37.008-52.204 27.45 0 37.009 29.411 37.009 52.204s-9.559 52.204-37.009 52.204c-29.41 0-37.008-27.94-37.008-52.204zm-765.954 46.877c27.109 0 39.186-24.66 39.186-47.109 0-23.907-14.537-47.087-39.186-47.087-24.897 0-39.45 23.18-39.45 47.087 0 22.449 12.077 47.109 39.45 47.109z" fill="#fff"/></g></svg>

                </a>
            </div>
            </li>
</ul>


                            <div class="icon__group">
                                <h6 class="m-b-15">Follow Symfony</h6>
                                <a href="https://github.com/symfony" title="Symfony on GitHub">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M8 0a8 8 0 0 0-8 8 8 8 0 0 0 5.47 7.59c.4.075.547-.172.547-.385 0-.19-.007-.693-.01-1.36-2.226.483-2.695-1.073-2.695-1.073-.364-.924-.89-1.17-.89-1.17-.725-.496.056-.486.056-.486.803.056 1.225.824 1.225.824.714 1.223 1.873.87 2.33.665.072-.517.278-.87.507-1.07-1.777-.2-3.644-.888-3.644-3.953 0-.873.31-1.587.823-2.147-.09-.202-.36-1.015.07-2.117 0 0 .67-.215 2.2.82a7.67 7.67 0 0 1 2-.27 7.67 7.67 0 0 1 2 .27c1.52-1.035 2.19-.82 2.19-.82.43 1.102.16 1.915.08 2.117a3.1 3.1 0 0 1 .82 2.147c0 3.073-1.87 3.75-3.65 3.947.28.24.54.73.54 1.48 0 1.07-.01 1.93-.01 2.19 0 .21.14.46.55.38A7.972 7.972 0 0 0 16 8a8 8 0 0 0-8-8"/></svg>
</i>
                                </a>
                                <a href="/slack" title="Symfony on Slack">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M5.042 15.165a2.528 2.528 0 0 1-2.52 2.523A2.528 2.528 0 0 1 0 15.165a2.527 2.527 0 0 1 2.522-2.52h2.52v2.52zM6.313 15.165a2.527 2.527 0 0 1 2.521-2.52 2.527 2.527 0 0 1 2.521 2.52v6.313A2.528 2.528 0 0 1 8.834 24a2.528 2.528 0 0 1-2.521-2.522v-6.313zM8.834 5.042a2.528 2.528 0 0 1-2.521-2.52A2.528 2.528 0 0 1 8.834 0a2.528 2.528 0 0 1 2.521 2.522v2.52H8.834zM8.834 6.313a2.528 2.528 0 0 1 2.521 2.521 2.528 2.528 0 0 1-2.521 2.521H2.522A2.528 2.528 0 0 1 0 8.834a2.528 2.528 0 0 1 2.522-2.521h6.312z"/><path d="M18.956 8.834a2.528 2.528 0 0 1 2.522-2.521A2.528 2.528 0 0 1 24 8.834a2.528 2.528 0 0 1-2.522 2.521h-2.522V8.834zM17.688 8.834a2.528 2.528 0 0 1-2.523 2.521 2.527 2.527 0 0 1-2.52-2.521V2.522A2.527 2.527 0 0 1 15.165 0a2.528 2.528 0 0 1 2.523 2.522v6.312z"/><path d="M15.165 18.956a2.528 2.528 0 0 1 2.523 2.522A2.528 2.528 0 0 1 15.165 24a2.527 2.527 0 0 1-2.52-2.522v-2.522h2.52zM15.165 17.688a2.527 2.527 0 0 1-2.52-2.523 2.526 2.526 0 0 1 2.52-2.52h6.313A2.527 2.527 0 0 1 24 15.165a2.528 2.528 0 0 1-2.522 2.523h-6.313z"/></svg>
</i>
                                </a>
                                <a href="https://twitter.com/symfony" title="Symfony on Twitter">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M16 3.038a6.62 6.62 0 0 1-1.885.517 3.299 3.299 0 0 0 1.443-1.816c-.634.37-1.337.64-2.085.79a3.282 3.282 0 0 0-5.593 2.99 9.307 9.307 0 0 1-6.766-3.42A3.222 3.222 0 0 0 .67 3.75c0 1.14.58 2.143 1.46 2.732a3.278 3.278 0 0 1-1.487-.41v.04c0 1.59 1.13 2.918 2.633 3.22a3.336 3.336 0 0 1-1.475.056 3.29 3.29 0 0 0 3.07 2.28 6.578 6.578 0 0 1-4.85 1.359 9.332 9.332 0 0 0 5.04 1.474c6.04 0 9.34-5 9.34-9.33 0-.14 0-.28-.01-.42a6.63 6.63 0 0 0 1.64-1.7z" fill-rule="nonzero"/></svg>
</i>
                                </a>
                                <a href="https://www.facebook.com/SymfonyFramework" title="Symfony on Facebook">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M15.117 0H.883A.883.883 0 0 0 0 .883v14.234c0 .488.395.883.883.883h7.663V9.804H6.46V7.39h2.086V5.607c0-2.066 1.262-3.19 3.106-3.19.883 0 1.642.064 1.863.094v2.16h-1.28c-1 0-1.195.48-1.195 1.18v1.54h2.39l-.31 2.42h-2.08V16h4.077a.883.883 0 0 0 .883-.883V.883A.883.883 0 0 0 15.117 0" fill-rule="nonzero"/></svg>
</i>
                                </a>
                                <a href="https://www.youtube.com/user/SensioLabs" title="Symfony on YouTube">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M0 7.345c0-1.294.16-2.59.16-2.59s.156-1.1.636-1.587c.608-.637 1.408-.617 1.764-.684C3.84 2.36 8 2.324 8 2.324s3.362.004 5.6.166c.314.038.996.04 1.604.678.48.486.636 1.588.636 1.588S16 6.05 16 7.346v1.258c0 1.296-.16 2.59-.16 2.59s-.156 1.102-.636 1.588c-.608.638-1.29.64-1.604.678-2.238.162-5.6.166-5.6.166s-4.16-.037-5.44-.16c-.356-.067-1.156-.047-1.764-.684-.48-.487-.636-1.587-.636-1.587S0 9.9 0 8.605v-1.26zm6.348 2.73V5.58l4.323 2.255-4.32 2.24z"/></svg>
</i>
                                </a>
                                <a href="https://symfonycasts.com/" title="Symfony Screencasts">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 300 300" xmlns="http://www.w3.org/2000/svg" xml:space="preserve" style="fill-rule:evenodd;clip-rule:evenodd;stroke-linejoin:round;stroke-miterlimit:1.41421"><path style="fill:none" d="M0 0h300v300H0z"/><clipPath id="a"><path d="M0 0h300v300H0z"/></clipPath><g clip-path="url(#a)"><path d="M300 30c0-16.557-13.443-30-30-30H30C13.443 0 0 13.443 0 30v240c0 16.557 13.443 30 30 30h240c16.557 0 30-13.443 30-30V30z" style="fill:#18171b"/><path d="M94.679 204.481c-4.374-1.925-9.01-2.625-13.734-2.625-18.632 0-32.278 12.51-32.278 31.317 0 19.42 12.859 31.841 32.191 31.841 3.587 0 9.272-.262 13.909-2.187l-.257-4.156a3.1 3.1 0 0 0-3.988-2.776c-2.99.903-6.622 1.421-9.577 1.421-12.684 0-23.006-9.534-23.006-23.881 0-13.733 9.36-23.881 23.444-23.881 3.038 0 5.994.528 8.787 1.582a3.098 3.098 0 0 0 4.178-2.646l.331-4.009zm13.522 19.85a3.1 3.1 0 0 0 4.404 2.615c2.741-1.268 5.876-1.996 8.866-1.996 8.223 0 11.022 3.937 11.022 11.635-3.237-.175-5.511-.175-8.748-.175-8.485 0-20.732 3.499-20.732 14.696 0 9.709 6.736 13.908 16.358 13.908 7.523 0 11.897-4.111 13.822-6.823h.175v5.774h4.352a3.098 3.098 0 0 0 3.093-3.296 125.34 125.34 0 0 1-.097-5.452v-18.458c0-12.159-5.161-18.457-17.933-18.457-5.686 0-10.585 1.75-14.696 4.199l.114 1.83zm44.173 38.234c3.761 2.012 8.048 2.449 12.247 2.449 7.96 0 15.57-4.373 15.57-13.908 0-14.259-19.332-11.635-19.332-20.732 0-3.674 3.674-5.424 7.873-5.424 1.107 0 3.2.377 5.127.913a3.097 3.097 0 0 0 3.926-2.68l.307-3.131c-3.237-.963-6.386-1.75-10.235-1.75-8.835 0-15.746 4.461-15.746 13.734 0 12.509 19.333 11.809 19.333 19.944 0 4.812-4.637 6.386-8.398 6.386-1.512 0-3.954-.43-6.366-1.29a3.097 3.097 0 0 0-4.141 2.732l-.165 2.757zm71.142 0c3.761 2.012 8.048 2.449 12.247 2.449 7.96 0 15.57-4.373 15.57-13.908 0-14.259-19.332-11.635-19.332-20.732 0-3.674 3.674-5.424 7.873-5.424 1.107 0 3.2.377 5.127.913a3.097 3.097 0 0 0 3.926-2.68l.307-3.131c-3.237-.963-6.386-1.75-10.235-1.75-8.835 0-15.746 4.461-15.746 13.734 0 12.509 19.333 11.809 19.333 19.944 0 4.812-4.637 6.386-8.398 6.386-1.512 0-3.954-.43-6.366-1.29a3.097 3.097 0 0 0-4.141 2.732l-.165 2.757zm-29.36-43.213v-12.947h5.123a3.1 3.1 0 0 1 3.099 3.1v9.847h11.81v3.548a3.1 3.1 0 0 1-3.1 3.1h-8.71v24.406c0 5.161 3.15 7.96 6.911 7.96.702 0 1.351-.06 1.947-.167a3.101 3.101 0 0 1 3.652 3.05v2.541c-1.837.525-4.374 1.224-6.999 1.224-8.485 0-13.733-4.024-13.733-12.946V226h-5.052a3.1 3.1 0 0 1-3.099-3.1v-3.548h8.151zm-61.663 27.292c0 6.649-4.286 11.722-12.422 11.722-3.761 0-8.31-2.537-8.31-7.26 0-7.873 11.022-8.573 15.483-8.573 1.75 0 3.499.175 5.249.175v3.936zm136.934-67.652H30.577c-.355-.024-.449-.012-.794-.109-1.164-.326-2.062-1.423-2.145-2.636a3.007 3.007 0 0 1 1.409-2.719c.344-.209.73-.346 1.129-.401.133-.019.268-.019.401-.028H53c-7.987-7.798-9.293-17.234-7.409-23.363 2.511-8.144 8.984-9.683 15.314-7.741 6.779 2.096 9.432 10.333 7.493 16.657-.216.677-.562 1.805-1.274 3.324-.787 1.738-2.245 3.272-2.869 5.31-.693 2.253.33 4.211 2.099 5.813h27.289c1.97-1.871 3.447-4.169 4.233-6.74 2.444-7.89-2.548-13.398-4.615-15.512l-10.054-10.762c-4.598-5.12-14.713-19.398-9.779-35.432 1.904-6.184 5.91-12.742 11.724-17.083 12.275-9.147 25.621-10.648 38.327-6.995 16.448 4.729 24.347 15.602 34.59 24.005 5.735-16.818 13.683-33.283 25.635-47.176 10.794-12.652 25.297-21.822 41.908-22.39 16.596-.548 29.142 6.974 29.556 18.882.167 5.068-2.74 14.92-12.864 15.261-7.572.262-12.8-4.263-13.036-11.135-.085-2.519.566-4.724 2.292-7.301 1.688-3.304 2.049-3.683 2.006-5.12-.152-4.333-6.692-4.493-8.482-4.409-24.548.811-31.018 33.939-36.263 60.875l-2.569 14.205c14.136 2.067 24.172-.481 29.77-4.102 7.881-5.117-2.205-10.374-.933-16.191 1.288-5.931 6.683-8.794 10.969-8.914 6-.148 10.283 6.077 10.144 12.395-.216 10.444-14.069 24.793-41.783 24.207a96.847 96.847 0 0 1-9.38-.665l-5.228 28.86c-1.387 6.478-2.91 13.66-4.945 21.237h94.561l.401.028c.132.027.265.045.394.082a3.005 3.005 0 0 1 2.09 2.237c.272 1.308-.46 2.759-1.711 3.302-.246.107-.506.18-.773.217-.132.018-.267.018-.401.027zm-127.085-5.893c.469-2.383.942-4.832 1.422-7.35l1.674-10.152c2.723-13.608 5.741-28.784 10.342-43.905-11.162-8.404-17.847-18.821-32.86-22.892-10.29-2.793-16.562-.423-20.973 5.155-5.222 6.604-3.488 15.2 1.557 20.241l8.336 9.223c10.222 11.808 15.809 20.999 13.707 33.359-1.024 6.057-3.949 11.682-8.315 16.321h25.11z" style="fill:#999"/></g></svg>
</i>
                                </a>
                                <a href="https://feeds.feedburner.com/symfony/blog" title="Symfony Blog RSS">
                                    <i class="icon"><svg width="16" height="16" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21H889q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5T250 902q-25-2-41.5-20T192 839V704q0-29 21-47 17-17 43-17h5q160 13 306 80.5T826 902q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5T1329 1476q-12-215-101-408.5t-231.5-336-336-231.5T252 398q-25-1-42.5-19.5T192 335V192q0-28 20-46 18-18 44-18h3q262 13 501.5 120T1186 542q187 186 294 425.5t120 501.5z"/></svg>
</i>
                                </a>
                            </div>

                            <div class="m-t-30 m-b-30">
                                <form>
                                    <label for="theme-switcher">
                                        <i class="icon icon--small icon--gray-dark"><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 512 512"><path d="M8 256c0 136.966 111.033 248 248 248s248-111.034 248-248S392.966 8 256 8 8 119.033 8 256zm248 184V72c101.705 0 184 82.311 184 184 0 101.705-82.311 184-184 184z"/></svg>
</i>
                                    </label>
                                    <select id="theme-switcher">
                                        <option value="light-theme">Light Theme</option>
                                        <option value="dark-theme">Dark Theme</option>
                                        <option value="dynamic-theme" selected>Dynamic (same as OS)</option>
                                    </select>
                                </form>
                            </div>
                            <script async>
                                const availableThemes = ['light-theme', 'dark-theme', 'dynamic-theme'];
                                const themeSwitcher = document.getElementById('theme-switcher');
                                const currentTheme = localStorage.getItem('themeName');
                                if (availableThemes.includes(currentTheme)) {
                                    themeSwitcher.value = currentTheme;
                                }

                                themeSwitcher.addEventListener('change', () => {
                                    const newTheme = themeSwitcher.value;

                                    document.body.classList.remove(...availableThemes);
                                    document.body.classList.add(newTheme);
                                    localStorage.setItem('themeName', newTheme);
                                });
                            </script>

                            <div class="m-t-30 m-b-30 text-small">
                                Copyright &copy; 2005 – 2021. Symfony SAS. All rights reserved.
                            </div>
                        </div>
                    </section>
                </footer>
                    </div>
        

        <div id="search-modal-backdrop" style="display: none">
            <div role="dialog" aria-modal="true" id="search-modal-content" tabindex="-1">
                <button aria-label="Close modal" id="search-modal-close-button">CLOSE</button>
                <form id="form-search" onsubmit="return false">
    <div class="form-group">
        <label for="form-search-input" class="sr-only">Search Symfony Docs</label>
                <input type="text"
               class="mousetrap form-control form-search-input"
               placeholder="Search Symfony Docs" aria-label="Search in Symfony documentation"
               autocapitalize="off" autocomplete="off" autocorrect="off" spellcheck="false"
               autofocus onkeyup="Search.makeQuery(this.value, event.key)" onclick="event.stopPropagation()">
    </div>
    <button type="submit" class="sr-only">Search</button>
</form>


<div class="form-search-results-wrapper">
    <div class="form-search-results"></div>
    <div class="form-search-results-footer">
        Search by <a target="_blank" href="https://algolia.com/?utm_source=symfony&utm_medium=link&utm_campaign=symfony_documentation">Algolia</a>
    </div>
</div>

            </div>
        </div>

        <script type="text/javascript">
            // load Connect bar
            window.addEventListener('DOMContentLoaded', function () {
                var js, fjs = document.getElementsByTagName('script')[0], load = function(url, id) {
                    if (document.getElementById(id)) { return; }
                    js = document.createElement('script'); js.src = url; js.id = id; js.defer = true;
                    fjs.parentNode.insertBefore(js, fjs);
                };
                load('https://connect.symfony.com/sln.js?customize_url=https://symfony.com/account/sln_customiser.js', 'sln_bar');

                var s = document.createElement('link');
                s.rel = 'stylesheet';
                s.href = 'https://connect.symfony.com/css/sln.css';
                var x = document.getElementsByTagName('title')[0];
                x.parentNode.insertBefore(s, x);
            });
        </script>
                    <script src="/build/755.f288b1ac.js"></script><script src="/build/app.b033b3db.js"></script>
            <script src="/build/468.2d2bcbaa.js"></script><script src="/build/search.6ee5efb9.js"></script>
            </body>
</html>
